Suite

Impossible de charger le plugin PRISM en raison d'une erreur lors de l'appel de sa méthode classFactory () dans QGIS1.8 inWin8


Lorsque je charge un plugin dans QGIS, j'ai rencontré quelques problèmes

J'avais essayé de copier d'autres fichiers Python27 dans le fichier Python 27 de QGIS mais cela ne fonctionne toujours pas.


Impossible de charger le plugin PRISM en raison d'une erreur lors de l'appel de sa méthode classFactory()

Traceback (appel le plus récent en dernier) : fichier "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", ligne 164, dans startPlugin plugins[packageName] = package.classFactory( iface) Fichier "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/pluginsPRISM__init__.py", ligne 25, in classFactory from prism import PRISM File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", ligne 309, dans _import mod = _builtin_import(name, globals, locaux, fromlist, level) Fichier "C:/PROGRA~2/Quantum GIS Lisboa/apps /qgis/./python/pluginsPRISMprism.py", ligne 15, dans import numpy File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", ligne 309, dans _import mod = _builtin_import(name, globals, locaux, fromlist, level) Fichier "C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packages umpy__init__.py", ligne 137, dans le fichier import add_newdocs "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", ligne 309, dans _import mod = _builtin_import(name, globals, locaux, fromlist, l evel) Fichier "C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packages umpyadd_newdocs.py", ligne 9, dans numpy.lib import add_newdoc Fichier "C:/PROGRA~2 /Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", ligne 309, dans _import mod = _builtin_import(name, globals, locaux, fromlist, level) Fichier "C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packages umpylib__init__.py", ligne 4, in from type_check import * Fichier "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgis utils.py", ligne 309, dans _import mod = _builtin_import(name, globals, locaux, fromlist, level) Fichier "C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packages umpylib ype_check.py", ligne 8, dans import numpy.core.numeric as _nx File "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", ligne 309, dans _import mod = _builtin_import(name, globals, locaux, fromlist, level) Fichier "C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packages umpycore__init__.py", ligne 5, en import fichier multiarray "C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./pythonqgisutils.py", ligne 309, dans _import mod = _builtin_import(name, globals, locals, fromlist, level) ImportError: DLL load échec : %1 O Ī Win32 ε{ C

Python 版本 : 2.7.5 (par défaut, 15 mai 2013, 22:43:36) [MSC v.1500 32 bits (Intel)]

QGIS : 1.8.0-Lisboa Lisboa, 6416f38

Python 路徑 : ['C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python', 'C:/Users/corbies/.qgis//python', 'C:/Users/corbies/.qgis //python/plugins', 'C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/plugins', 'C:Program FilesIntergraphERDAS IMAGINE 2014usrlibWin32Releasepython ', 'C:WINDOWSSYSTEM32python27.zip', 'C:PROGRA~2Quantum GIS LisboaappsPython27DLLs', 'C:PROGRA~2Quantum GIS LisboaappsPython27 lib', 'C:PROGRA~2Quantum GIS LisboaappsPython27libplat-win', 'C:PROGRA~2Quantum GIS LisboaappsPython27liblib-tk', ' C:PROGRA~2Quantum GIS Lisboaappsqgisin', 'C:PROGRA~2Quantum GIS LisboaappsPython27', 'C:PROGRA~2Quantum GIS LisboaappsPython27 libsite-packages', 'C:Program Files (x86)ArcGISDesktop10.2in64', 'C:Program Files (x86)ArcGISDesktop10.2arcpy', 'C: Program Files (x86)ArcGISDesktop10.2ArcToolboxScripts', 'C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packagesPIL', 'C:PROGRA~2 Quantum GIS LisboaappsPython27libsite-packag eswin32', 'C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packageswin32lib', 'C:PROGRA~2Quantum GIS LisboaappsPython27lib site-packagesPythonwin', 'C:PROGRA~2Quantum GIS LisboaappsPython27libsite-packageswx-2.8-msw-unicode', 'C:PROGRA~2Quantum GIS Lisboa appsqgispythonpluginsfTools ools']

Je pense que le plugin conçu pour QGIS 1.8-1.99


Le plugin n'est pas dans le dépôt officiel.

Vous devez vous assurer que cela fonctionnera avec QGIS 1.8. La plupart des plugins sont conçus pour fonctionner avec QGIS 2.0 et versions ultérieures uniquement.


Voir la vidéo: Comment résoudre lerreur ng impossible de charger le fichier sous Angular (Octobre 2021).