Suite

Impossible de sélectionner des points avec un rectangle (ArcMap)


J'utilise ArcGIS 10.2, ArcMap et j'ai une couche de points de fichier de formes dans laquelle je ne peux sélectionner aucun point. (J'ai le même problème que cette personne décrit mais aucune des solutions suggérées ne fonctionne : pourquoi la sélection en dessinant un rectangle ne fonctionne-t-elle pas dans ArcGIS ?)

Pour simplifier les choses, j'ai supprimé toutes les autres couches de la carte. J'ai surligné la couche dans la table des matières. J'ai également fait : clic droit > Sélection > " Faire de ce calque le seul calque sélectionnable dans le tableau ". J'ai essayé lasso, rectangle, polygone, sans succès. Lorsque j'ajoute une couche de polygones à la carte, je peux sélectionner des polygones avec ces outils. J'ai également ajouté une couche de points différente à la carte et j'ai pu sélectionner ces points. Mais il y a quelque chose à propos de cette couche de points. C'est dans GCS_WGS_1984, pas que cela devrait avoir quelque chose à voir avec ça (la couche de polygones que je peux également sélectionner est également dans GCS_WGS_1984).

Des suggestions supplémentaires?


Cela semble être l'une des nombreuses choses. Une idée cependant est d'aller dans les paramètres de votre menu de paramètres de sélection interactive dans le MXD (Sélection> Méthode de sélection interactive) et dans ce sous-menu, assurez-vous que la bonne option est sélectionnée, vous voudrez probablement Créer une nouvelle sélection. Si cela était modifié, cela pourrait fonctionner correctement en ne sélectionnant rien, si par exemple il était configuré pour être supprimé de la sélection actuelle, chaque fois que vous essayez de sélectionner des fonctionnalités, il essaie de désélectionner ces fonctionnalités.

De plus, encore une fois, je ne sais pas s'il s'agit de votre problème particulier ou non, mais vous souhaiterez peut-être accéder à Sélection> Options de sélection et assurez-vous que les paramètres sont pertinents pour votre cas d'utilisation. Une chose à noter que je pense que pour vous serait, si vos points sont en fait des entités multi-points, alors vous devez absolument vérifier qu'il est configuré pour sélectionner des entités partiellement ou complètement dans la boîte ou le graphique. Si vous ne l'avez pas défini correctement et qu'il s'agit d'entités multi-points, vous pouvez rencontrer des problèmes car tous les points de chaque entité ne se trouvent pas dans la zone de sélection.

Je sais que ce ne sont en aucun cas les deux seules causes possibles, et d'après les mesures que vous avez prises pour vérifier avec d'autres ensembles de données, je doute que ce soit le cas, mais, comme je ne connais pas les détails de votre situation, ce n'est pas le cas. ça ne fait pas de mal d'essayer de toute façon.

Écoutez bien les deux commentaires sur votre question, exécutez l'outil de vérification de la géométrie et, si nécessaire, la géométrie de réparation. Essayez également de l'afficher dans un autre MXD ; et je ne veux pas dire faire glisser/copier le calque de votre MXD actuel et le faire glisser/coller dans un nouveau MXD, je veux dire ouvrir un nouveau MXD et ajouter des données et ajouter les données de la source.

De plus, si rien de tout cela ne fonctionne, au moins à des fins de test, essayez de convertir/exporter le jeu de données en question dans un format différent et testez-le là-bas (par exemple, s'il s'agit actuellement d'un fichier de formes, exportez vers une classe d'entités FileGDB, s'il est une classe d'entités FileGDB, exportée vers un fichier de formes. De cette façon, vous pouvez au moins savoir s'il s'agit d'un problème avec les données elles-mêmes, ou s'il s'agit d'un problème uniquement avec ce fichier.


La même chose m'est arrivée et c'est parce que le fichier de formes a été joint à un tableau Excel. Il semble que l'outil "Sélectionner par emplacement" ne fonctionne pas sur un fichier de formes qui a une jointure. une fois que j'ai supprimé la jointure, l'outil de sélection a fonctionné comme prévu.


Je suis sûr que cela a déjà été résolu d'une manière ou d'une autre, mais j'avais le même problème. J'ai importé une couche d'événement XY et je n'ai pu sélectionner aucun des points de cette couche. Les données étaient toutes là et les points situés correctement, c'était donc un casse-tête.

Ma solution consistait à reprojeter la nouvelle couche XY dans le système de coordonnées utilisé dans la carte actuelle. Cela l'a résolu pour moi.


Il m'est arrivé la même chose et la même solution a fonctionné. Je suis dans ArcMap 10.3.1 et j'exécute tous les deux une sélection par emplacement dans un modèle dans Model Builder et l'exécution manuelle d'une sélection par emplacement ne sélectionnerait que certaines des fonctionnalités qui entrent dans les paramètres.

La fermeture et la réouverture d'ArcMap ont fait l'affaire !


Voir la vidéo: Merge Shapefile using Union Tool in ArcGIS - ArcGIS for Beginners (Octobre 2021).