Suite

Qu'est-ce qui provoque l'effacement des données lors de l'ajout d'un domaine dans ArcGIS 10.2.2 et ArcGIS Online ?


J'ai des données spatiales dans ArcGIS 10.2.2 que je partage en tant que service, puis que je visualise dans ArcGIS Online. Les données se composent du prénom et du nom des employés, séparés par un seul espace, c'est-à-dire « John Smith ». Les noms de famille ont été omis dans l'exemple de capture d'écran ci-dessous représentant l'affichage réussi des données.

Je voudrais ajouter un domaine à un champ pré-rempli qui contraint l'entrée dans ce champ. Le problème est que lorsque j'ajoute ce domaine dans ArcMap 10.2.2, puis partage le résultat en tant que service, puis l'affiche en tant que carte, les données elles-mêmes ne s'affichent plus dans ArcGIS Online.

Vous trouverez ci-dessous un exemple des contraintes de domaine. J'ai assuré que chaque nom déjà présent dans la base de données est représenté dans la définition du domaine, afin de garantir que le problème n'est pas que les données préexistantes ne sont pas autorisées dans le nouveau domaine.

Et enfin, voici le résultat dans ArcGIS Online lorsque le domaine ci-dessus est appliqué au Champ des noms d'employés.

Pourquoi cela peut-il se produire et que puis-je faire pour le résoudre ?

Éditer: Pour rendre cela encore plus déconcertant, j'ai suivi les conseils d'ajout d'un champ, de définition du domaine, puis de remplissage via la calculatrice de champ, et cela n'a toujours pas fonctionné !


Voir la vidéo: Lutilisation de services Web dans ArcGIS Pro et ArcGIS Online (Octobre 2021).