Suite

L'installation de GDAL sur Ubuntu 12.04 fonctionne pour python 2.x mais pas pour python3


J'ai besoin d'installer gdal 1.10 ou supérieur pour être compatible avec python3 sur ubuntu 12.04. Python2 est également installé sur la machine.

J'ai suivi les instructions ici Erreur lors de l'installation de GDAL dans Ubuntu 12.04. Cela a installé avec succès gdal pour python2.x mais pas python3. j'ai essayé la commandesudo apt-get install gdal-bin python3-gdalmais je suis accueilli avec l'erreur "Impossible de localiser le pacage python3-gdal"

j'ai aussi essayésudo pip3 installer gdal

Comment puis-je installer gdal avec succès pour python3 ?


UbuntuGIS contient GDAL 1.10.0-1 avec des liaisons Python3.

sudo add-apt-repository ppa:ubuntugis/ppa && sudo apt-get update sudo apt-get install gdal-bin python3-gdal

Vous pouvez également construire GDAL à partir des sources avec le support Python3, mais cela nécessiterait l'installation des bibliothèques dépendantes (et la résolution de nombreux problèmes de construction pendant que vous y êtes).